Accueil > SharePoint 2013 > SharePoint 2013 (Beta) : Installer un serveur standalone

SharePoint 2013 (Beta) : Installer un serveur standalone


 

Note :  Cet article s’applique à la version BETA de SharePoint 2013. Pour la version RTM, rendez-vous sur cet article (standalone)ou sur cet autre article (ferme).

J’avais détaillé dans ce post les contournements possibles pour 2 erreurs rencontrées lors de l’installation d’un serveur SharePoint 2013 standalone.

Vous trouverez dans ce post une autre méthode d’installation, ainsi que le moyen d’arriver à faire fonctionner le wizard jusqu’au fameux « Configuration successful ».

* Edit 1 (18/09) :  Finalement ce mode d’installation (décrit au cas n°3) comporte encore des problèmes, notamment lors de la création d’une application de service de recherche (via PowerShell en l’occurrence), et peut-être ailleurs …

* Edit 2 (18/09) :  « Configuration successful », ma première sur une installation standalone …

Configuration successful !

Lorsque vous rencontrez l’erreur sur les « sample data », on voit dans les logs ULS que l’erreur est décrite dans la stack(notamment) par la ligne « Microsoft.Office.Server.Search.Administration.AnalyticsAdministration.CreateAnalyticsUNCShare ».

Ce « Share » posant problème concerne le répertoire suivant (Analytics_GUID); il est créé une fois que vous avez lancé une première fois le wizard :

J’ai effectué 2 actions sur ce répertoire avant de relancer le wizard :

  • Attribué le droit de « Full Control » à « Everyone »,
  • Créé manuellement un partage via « Advanced Sharing ».

Je ne sais pas lequel des 2 (ou les 2) corrige(nt) le problème, c’est sale, mais çà fonctionne :

J’ai effectué cette action dans le cadre du cas n°3 décrit ci-dessous (installation via Power Shell + du coup lancement du wizard car problèmes sur le search), mais je pense que cela doit fonctionner dans tous les cas (sauf le n°1 de ci-dessous, bien sûr).

Voici un résumé de mes installations en standalone :

Cas 1 : Installation classique via le wizard

Vous pouvez oublier, la configuration »classique »  ne fonctionne pas avec cette béta.

Cas 2 : Installation classique via psconfig – SkipRegisterAsDistributedCacheHost

C’est la méthode décrite dans ce post.

Le wizard plante à l’étape de création des « Sample Data »; l’administration centrale est fonctionnelle, et il est possbile d’utiliser SharePoint au moins de manière basique (applications web, collections de sites, ….).

Malgré un SharePoint à priori fonctionnel, il s’avère que des limitations existaient, par exemple l’impossibilité de créer des « Managed Accounts » via l’administration centrale; erreur rencontrée : « Requested registry access is not allowed. »

En regardant dans les logs on trouve alors ce genre de choses « SPDistributedCacheClientFactory::InitializeDataCacheFactory – SPDistributedCacheClusterInfo is null », ce qui fait quand même penser que passer par la commande “psconfig -cmd Configdb create SkipRegisterAsDistributedCacheHost” n’est peut-être pas une solution viable, en tout cas pour certaines fonctionnalités.

Cas 3 : Installation via PowerShell

1. Installez SharePoint (en standalone, donc) comme d’habitude, et sans lancer le wizard à la fin.

2. Après avoir exécuté l’installeur, ouvrez une invite de commande PowerShell via « SharePoint 2013 Management Shell ».

Ignorez les messages d’erreur.

3. Lancez la commande suivante, en remplaçant les paramètres adéquats :

  • Nom de la base de données de configuration (ici SharePointConfig),
  • Nom de la base de données de l’admin centrale (ici SharePointAdminContent),
  • Nom de votre serveur (ici WFEC).

Vous aurez à saisir les login et mot de passe du compte de la ferme via une popup, puis la passphrase de la ferme (cliquez sur l’image pour l’ouvrir en grand).

4. Après quelques (très longues) minutes, l’exécution de la commande s’achève : lancez le wizard de configuration ou exécutez les commandes suivantes :

  • Install-SPHelpCollection -All
  • Initialize-SPResourceSecurity
  • Install-SPService
  • Install-SPFeature -AllExistingFeatures
  • New-SPCentralAdministration -Port 5555 -WindowsAuthProvider « NTLM »
  • Install-SPApplicationContent

Note : j’ai choisi « 5555 » comme numéro de port mais vous pouvez bien sûr en choisir un autre.

* Résultat via les commandes (mode que je préfère)

Aucune erreur lors de l’exécution des commandes : en plus d’avoir l’administration  centrale fonctionnelle, le compte de la ferme est bien enregistré comme « Managed account », et je peux également en rajouter.

De même, la création d’une application web et d’une collection de site fonctionnent également, ce mode d’installation semble donc être efficace, pour du basique.

* Résultat via le wizard

J’ai de nouveau rencontré des erreurs lors de création des « Sample data », mais le résultat semble identique à celui de l’exécution des commandes.

Conclusion

Autant les installations en mode ferme fonctionnent correctement, je n’ai rencontré aucun souci, autant ces installations en mode standalone sont assez pénibles.

Vivement une prochaine version publique de SharePoint 2013 !

Sinon, vous pouvez toujours allez voir cet article pour réaliser une installation d’une ferme SharePoint 2013 (1 DC, 1 SQL, 1 WFE/applicatif).

  1. septembre 19, 2012 à 10:11

    Reblogged this on SharePoint, Le travail collaboratif par excellence and commented:
    Excellent article… Très utile pour une première installation😉

  1. No trackbacks yet.

Laisser un commentaire

Entrez vos coordonnées ci-dessous ou cliquez sur une icône pour vous connecter:

Logo WordPress.com

Vous commentez à l'aide de votre compte WordPress.com. Déconnexion / Changer )

Image Twitter

Vous commentez à l'aide de votre compte Twitter. Déconnexion / Changer )

Photo Facebook

Vous commentez à l'aide de votre compte Facebook. Déconnexion / Changer )

Photo Google+

Vous commentez à l'aide de votre compte Google+. Déconnexion / Changer )

Connexion à %s

%d blogueurs aiment cette page :